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Steps Required to Set Up TRIM.FaTE Training Application
(revised on 9/29/2005)

This file provides step-by-step instructions for creating a training application of TRIM.FaTE
using the provided data files and the Public Reference library accompanying TRIM.FaTE.

NOTE:  This application is for training purposes only and is not intended to apply to any real
world situation.

1. Open TRIM.FaTE by typing “runfate.bat” from a run or command window, by double
clicking on the icon (if you created one) for TRIM.FaTE on your desktop, or by selecting
FaTE from the TRIM menu in the Windows Start Menu Programs list.

2. Open the Public Reference library by first selecting “Open Library” from the File menu
of the Main TRIM.FaTE window and then using the File Browser that appears to select
the Public Reference library file (i.e., IntegratedPublicReferenceLibrary_071205.trl). 
Once you have selected the file, click “Open Library.”

3. In this step, you will first set the diets for the biotic compartments, as well as their
density in the study area.  [See TRIM.FaTE User’s Guide Module 6 for more information
on implementing biota in a scenario.] Then, you will set site-specific values for the
abiotic compartments.

Select “Compartments” from the Contents pull-down list at the top, left-hand side of the
Object Browser.  Choose (by highlighting) one of the compartments listed in the table
below from the list of compartments in the Object Browser and click the “Properties”
button below the list.  The properties for the selected compartment will appear on the
right-hand side of the Library window in a Property Editor.  Either click or double-click
on the “Value” field for one of the properties listed in the table below for the selected
compartment (the value for each of these properties should be “<unset>” in the current
library).   Backspace to erase the current entry, type in the number from the table below
(in the “Site-specific value” column), and hit Enter before moving to the next property.  
Repeat this step for each of the compartments and properties in the table below.

Compartment Property Name Site-specific Value

Biotic

Bald eagle

FractionDietChickadee 0.1
FractionDietFishbenthiccarnivore 0.17
FractionDietFishbenthicomnivore 0.17
FractionDietFishcarnivore 0.11
FractionDietFishherbivore 0.11
FractionDietFishomnivore 0.11
FractionDietMouse 0.23
NumberofIndividualsPerSquareMeter 1.3E-08
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Benthic carnivore

FractionDietFishbenthicomnivore 1
FractionDietFishcarnivore 0
FractionDietFishherbivore 0
FractionDietFishomnivore 0
NumberofFishperSquareMeter 1.07E-04

Benthic invertebrate BiomassPerArea_kg_m2 0.0373

Benthic omnivore

FractionDietBenthicInvertebrate 1
FractionDietFishbenthiccarnivore 0
FractionDietFishcarnivore 0
FractionDietFishherbivore 0
FractionDietFishomnivore 0
NumberofFishperSquareMeter 7.55E-03

Black-capped chickadee
FractionDietPlant 0.3
FractionDietSoilArthropod 0.7
NumberofIndividualsPerSquareMeter 3.5E-05

Common loon

FractionDietFishbenthiccarnivore 0
FractionDietFishbenthicomnivore 0.5
FractionDietFishcarnivore 0
FractionDietFishherbivore 0
FractionDietFishomnivore 0.5
NumberofIndividualsPerSquareMeter 4.9E-08

Long-tailed weasel

FractionDietMouse 0.5
FractionDietshorttailedshrew 0.25
FractionDietvole 0.25
NumberofIndividualsPerSquareMeter 6.5E-06

Mallard

FractionDietBenthicInvertebrate 0.335
FractionDietMacrophyte 0
FractionDietPlant 0.665
NumberofIndividualsPerSquareMeter 9.3E-06

Meadow vole
FractionDietPlant 1
FractionDietSoilArthropod 0
NumberofIndividualsPerSquareMeter 6.0E-03

Mink

FractionDietBenthicInvertebrate 0.17
FractionDietChickadee 0.08
FractionDietFishbenthiccarnivore 0
FractionDietFishbenthicomnivore 0.15
FractionDietFishcarnivore 0
FractionDietFishherbivore 0.103
FractionDietFishomnivore 0.037
FractionDietMouse 0.23
FractionDietvole 0.23
NumberofIndividualsPerSquareMeter 6.0E-07

Mouse

FractionDietPlant 0.5
FractionDietSoilArthropod 0.5
FractionDietWorm 0
NumberofIndividualsPerSquareMeter 2.3E-03
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Raccoon

FractionDietFishbenthiccarnivore 0
FractionDietFishbenthicomnivore 0.046
FractionDietBenthicInvertebrate 0.69
FractionDietFishcarnivore 0
FractionDietFishherbivore 0.04
FractionDietFishomnivore 0.014
FractionDietWorm 0.21
NumberofIndividualsPerSquareMeter 2.15E-05

Red-tailed hawk

FractionDietChickadee 0.257
FractionDietMouse 0.303
FractionDietshorttailedshrew 0.2
FractionDietSoilArthropod 0.04
FractionDietvole 0.2
NumberofIndividualsPerSquareMeter 6.7E-07

Short-tailed shrew
FractionDietSoilArthropod 0.415
FractionDietWorm 0.585
NumberofIndividualsPerSquareMeter 6.1E-04

Tree swallow FractionDietEmergingBenthicInsects 1
NumberofIndividualsPerSquareMeter 7.0E-04

Water column carnivore

FractionDietBenthicInvertebrate 0
FractionDietFishbenthiccarnivore 0
FractionDietFishbenthicomnivore 0
FractionDietFishherbivore 0
FractionDietFishomnivore 1
NumberofFishperSquareMeter 8.95E-05

Water column herbivore

FractionDietAlgae 1
FractionDietBenthicInvertebrate 0
FractionDietMacrophyte 0
NumberofFishperSquareMeter 0.0658

Water column omnivore

FractionDietBenthicInvertebrate 0
FractionDietFishbenthiccarnivore 0
FractionDietFishbenthicomnivore 0
FractionDietFishcarnivore 0
FractionDietFishherbivore 1
FractionDietMacrophyte 0
NumberofFishperSquareMeter 2.34E-03

White-tailed deer FractionDietPlant 1
NumberofIndividualsPerSquareMeter 4.6E-05

Worm ArealDensity_Freshweight 0.045
Abiotic

Sediment OrganicCarbonContent 0.02
Soil - Root zone OrganicCarbonContent 0.0166

Soil - Surface
OrganicCarbonContent 0.0166
TotalErosionRate_kg_m2_day 2.89E-04
TotalRunoffRate_m3_m2_day 1.01E-03

Soil - Vadose zone OrganicCarbonContent 1.28E-03
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Surface water
AlgaeDensityinWaterColumn_g_L 2.5E-03
ChlorophyllConcentration_mg_L 5.3E-03
OrganicCarbonContent 0.02

4. Select “Sources” from the Contents pull-down list at the top of the Object Browser.  Next
select “Generic Source” from the list of sources in the Public Reference library (it is the
only one listed) and click the “Properties” button below the list.  The properties for
“Generic Source” will appear on the right-hand side of the Library window in a Property
Editor.  Input the source-specific values listed in the table below for the elevation, X, and
Y properties (the value for each of these properties should be “<Unset>” in the current
library).  Next, input the source- and chemical-specific values in the table below for the
emissionRate properties (the value for each of these properties should also be “<Unset>”
in the current library).

Source Property Name Chemical Value

Generic Source elevation - 0.01
Generic Source emissionRate Benzo(a)pyrene 0.0
Generic Source emissionRate Divalent Mercury 17.663
Generic Source emissionRate Elemental Mercury 335.6
Generic Source emissionRate MethylMercury 0.0
Generic Source X - 513770.42
Generic Source Y - 4953955.63

5. Save the library with a new name (e.g., TrainingApplicationLibrary.trl) by selecting
“Save Library As” from the Library window and, using the File Browser window that
appears, selecting a location for the new library and typing the name of the new library in
the box beside “File name.”  This library can be named however you choose.  After
saving the new library, close the Library window by selecting “Close Library” from the
Library window’s File menu.

6. Create a new project by selecting “New Project” from the File menu of the Main
TRIM.FaTE window.  Enter a name for the new project (e.g., “TrainingApplication”) in
the Name New Project window that appears and click “OK.”  The project can be named
however you choose.  Then enter “Training” in the Name Scenario for project window
that appears and click “OK.”  In order for the scenario to use provided input data files,
the scenario must be named “Training.”

7. Add the library to the project by clicking “Add” under the Libraries pane of the Project
window, selecting the library saved in Step 5 using the File Browser that appears, and
then clicking “Add Library to Project.”

8. Open the scenario by double-clicking on “Training” in the Scenarios pane of the Project
window.  Alternatively, the scenario can also be opened by selecting “Training” and
clicking the “FaTE...” button under the Scenarios pane of the Project window.
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9. In this step, you will specify the coordinates of the parcels and dimensions of the volume
elements for the scenario by importing the prepared volume element file.  [See
TRIM.FaTE User’s Guide Modules 5 and 3 for details.] 

Import the volume elements into the scenario by selecting “Import Volume Elements...”
from the File menu of the Scenario window.  In the Map Projections window that
appears, select “Universal Transverse Mercator” next to “Available Projection Families”
and  “GRS 1980" next to “Ellipsoids.” Optionally, you can provide a name for the
projection next to “Name:” but it is not required.  In the table at the bottom of the
window, enter “19" as the value for the “UTM Zone” parameter and press “Enter.”  Next,
click “OK.”  Use the File Browser that appears to select the
Training_VolumeElements.txt file (which was downloaded earlier) and click “Import
Volume Elements.”  After processing the file, the Volume Element Importer window will
appear with the message “Found 86 volume elements.”  Click “OK.”  Next, the Import
Completed window will appear with the message “Import process is complete.”  Click
“OK.”

To see the newly imported volume elements, select the “compartments” tab and the
volume elements can be easily seen when “volume elements” are selected in the drop
down menu in the “Outdoor Environment” pane.  For reference, the parcels associated
with these volume elements are illustrated in the following files included in
trainingapplication.zip: AirParcels.pdf and SurfaceParcels.pdf.

10. Import the compartments into the scenario by selecting “Read Compartments from File”
from the File menu of the Scenario window.  Use the File Browser that appears to select
the Training_Compartments.txt file (which was downloaded earlier) and click “Open.” 
The Add Complete window will appear with the message “165 Compartments were
added to 30 volume elements.”  Click “OK.”

11. Open the Training_Properties.txt file (which was downloaded earlier) using a text editor
and update all of the file paths in the values of the properties whose Form is
“InputFromFile” to correspond to the location of these files on your computer.  This is
necessary if you did not place the Training Application files into a directory named
“C:\Models\TRIM\data\Training.”  With most text editors, this can be done using the
“Replace” feature (replacing “C:\\Models\\TRIM\\data\\Training” with the directory
where you have placed these files - using the double slash convention).  Alternatively, the
“Search” function can be used to find all instances of the text string “InputFromFile,” and
the file location on the following line must then be updated.  

After updating all of the file paths, change the value of the scenario property outputDir (it
is towards the beginning of the file) to indicate the location on your computer where the
output files from the simulation should be written.
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Important Note: The file locations in the Training_Properties.txt file must use two
backward slashes (i.e., “\”) instead of the typical single backward slash to indicate the
directory hierarchy.  For example, the file path “C:\Models\TRIM” should be written as
“C:\\Models\\TRIM” in the Training_Properties.txt file.

After all of the file locations and the outputDir property value have been updated, save
the file and close the text editor.

12. Import the Training_Properties.txt file by selecting “Load Properties from File” from the
File menu of the Scenario window.  The Load Properties for Training window will
appear.  Click the “Browse” button in the Run File Name pane and use the File Browser
that appears to select the Training_Properties.txt file.  After selecting the file, click
“Open.”  After “BaseRun” appears in the Runs pane, click “Override.”  The Properties
Overridden will appear with the message “The properties were overridden successfully.” 
Click “OK.”  Next, click “Close” in the Load Properties for Training window.

13. Select the Sources tab in the Scenario window.  Next, select “Generic Source” from the
Sources in Libs pane and click the “<< Add” button beneath the pane.  This will add
“Generic Source” to the Sources in Scen pane.

14. Select the Chemicals tab in the Scenario window.  Next select “Divalent Mercury”
“Elemental Mercury” and “MethyMercury” by holding down the Ctrl key and clicking on
each.  Then click the “<<Add” button beneath the pane.  This will add these three
chemicals to the Chemicals in Scen pane.

To view the components of the new scenario, click the various tabs of the Scenario
window.  For example, clicking the “Compartments” tab will show the compartments or
volume elements that are now part of the scenario.

15. This step uses “SmartLink” to set most of the links needed among compartments, while
the next step uses a text file to set the remainder.  [See TRIM.FaTE User’s Guide Module
8 for more details on links.] 

Select the Links tab in the Scenario window.  Select all of the volume elements in the
left-most “Outdoor Environment” pane (by holding down the Ctrl or Shift key and
highlighting all volume elements in this pane) and click the “Smart Link” button beneath
the right-most “Outdoor Environment” pane.  The Smart Link Warnings window will
appear with the message indicating there were a number of warnings.  Click “Ignore.” 
The Smart Link Completed window will appear with the message “The Smart Link
process has completed.”  Click “OK.”

The new links can be viewed in the Outdoor Environment tree structure by selecting the
“Links” tab of the scenario window.



-7-

16. Import the Training_LinkProperties.txt file by selecting “Load Properties from File” from
the File menu of the Scenario window.  The Load Properties for Training window will
appear.  Click the “Browse” button in the Run File Name pane and use the File Browser
that appears to select the Training_LinkProperties.txt file.  After selecting the file, click
“Open.”  After “BaseRun” appears in the Runs pane, click “Override.”  The Properties
Overridden will appear with the message “The properties were overridden successfully.” 
Click “OK.”  Next, click “Close” in the Load Properties for Training window.

17. While on the Scenario tab, scroll down to the properties on the right-hand side called
“simulationBeginDateTime” and “simulationEndDateTime.”  Together these properties
define the duration of the simulation.  On a two gigaHertz Pentium 4 computer, a 30 year
duration for this simulation may take 18 to 24 hours of run time.  To set a shorter
duration (with associated shorter run time), adjust the value of the
“simulationEndDateTime” property.  For example, for a one-year simulation
(approximately 80-90 minutes of run time with a one gigaHertz Pentium 4 computer) set
the “simulationEndDateTime”  property to “01/01/1988 00:00:00 EST.”

The change in run time is roughly linear with simulation duration, such that to achieve a
run time on the order of 10 minutes for this scenario you'd need to set the duration to
either one or two months (depending on your computer’s processor).  You might want to
do this just to get a feel for how things work and what the results look like, while
recognizing that a longer duration will be necessary to get a better handle on ultimate
multimedia distribution of the pollutant.

18. If you intend to use the output from TRIM.FaTE in TRIM.Risk, additional scenario
properties need to be set.  If you are not planning to run TRIM.Risk, you can skip this
step and proceed to step 19.

In the Scenario tab, the following properties must set to create output for TRIM.Risk in
the form of a MySQL database.  (If any one of these properties is not listed in the
scenario property list, you can add the property by clicking on the “new” button on the
top of the list of scenario properties.  Scroll through the list to the property name,
highlight it, click “OK,” select <None> in the next window because these properties are
not chemical specific, and select “OK” again.)

• exportRiskEcoInputs: Scroll through the property list to locate this property, and
set the value to “true.”  This property must be set to true to create the output
MySQL database for TRIM.Risk.

• exportAllResultstoDB: Scroll through the property list to locate this property, and
set the value to “true.”  This property must be true so that TRIM.FaTE exports the
required results to the MySQL database.
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• exportAvgResultstoDB: Scroll through the property list to locate this property,
and set the value to “true” to tell TRIM.FaTE to export average results to the
database (this property is optional).

• exportConcentration:  Scroll through the property list to locate this property, and
check that this property is set to “true.”  This property must be set to true to
export concentration results to the database.

• exportBiotaIntakeRates: Scroll through the property list to locate this property,
and check that this property is set to “true” (this property is optional).

• mySQLDataDir: Scroll through the property list to locate this property, and set
the value to the “data” directory within the MySQL installation on your computer
(e.g., C:\Program Files\MySQL\MySQL Server 4.1\data).

19. Save the Project by selecting “Save Project” from the “File” menu” of the Project
window.

20. Verify the scenario by selecting “Verify Scenario” from the Run menu of the Scenario
window.  The Verification Results for Scenario Training window will appear indicating
that the verification of the Training simulation was “Successful.”

If the verification results indicate that the simulation has “Failed,” a Training Errors
window will appear.  Common errors for the Training Application are typically due to
missing values (or typos) from the site-specific values input in Steps 3 and 4.  In order to
run the scenario, these errors need to be fixed.  To view the errors for a Failed simulation,
click “Show.”  If you forgot to enter the fraction diet value for the white-tailed deer (i.e.,
FractionDietPlant), for example, you would see a list of errors associated with this
property not being set.  An example of one of the errors in the Training Errors window
would be as follows:
“Required property not set: Property FractionDietPlant in Compartment White-tailed Deer in
SurfSoil_SSE4 is not set but is required by property transferFactor in Algorithm Ingestion of Leaf
Particles by White-tailed Deer”

To fix the error in this example, click “Hide” to minimize the errors, and go to the
Compartments tab in the Training Scenario.  Then add the correct fraction diet for the
white-tailed deer in all of the necessary compartments.  For the error listed above (e.g.,
SurfSoil_SSE4), double-click on the SurfSoil_SSE4 volume element folder, select the
White-tailed deer compartment folder and click on “Properties,” and add the correct
fraction (i.e., 1) as the value for the FractionDietPlant property.  Once all of the errors
have been addressed, first save the updated scenario, and then verify the scenario by
selecting "Verify Scenario" from the Run menu of the Scenario window.
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21. Start the simulation by selecting “Run Scenario” from the Run menu of the Scenario
window.  The Perform Verification window will appear to ask the user if they would like
to perform a verification before starting the simulation.  Click “No.”  After the simulation
completes, the Simulation Results for Scenario Training window will appear indicating
that the Training simulation was “Successful.”

22. The results of the run can be viewed within TRIM.FaTE with the Results viewer or
Graphical results viewer.  [See TRIM.FaTE User’s Guide Module 14 for more
information on outputs.]  For example, the results can be viewed by clicking on “Run
Results” or “Graphical Results” in the “View” menu of the Scenario window.


